Problems with commands
Incident Report for Circle
Postmortem

During the incident window, all bans, kicks, mutes, and warnings would be processed, however, the modlog would not properly create.

This incident was caused by several factors, a Discord incident which seemed to be the root cause as well as problem at our database layer causing modlog creation queries to fail. We have resolved the database error and are working to ensure it does not happen again.

Our response to this issue was delayed due to our logs being flooded with Discord’s API returning HTTP 503 (service unavailable). We are implementing policy changes to ensure we do not have delayed responses to issues like this again.

All impacted customers can reach out to our support team if they require we manually add modlogs to their server’s database.

Posted Jan 03, 2024 - 17:19 PST

Resolved
This incident has been resolved.
Posted Jan 03, 2024 - 17:04 PST
Update
We are no longer observing elevated errors, this incident will be left open until we are certain the issue is resolved.
Posted Jan 03, 2024 - 16:46 PST
Identified
This issue looks like its being caused by Discord. We are observing an abnormal number of HTTP 503 errors from the Discord API.
Posted Jan 03, 2024 - 16:39 PST
Investigating
We are aware of many commands returning "Something went wrong" errors. The team is investigating.
Posted Jan 03, 2024 - 16:12 PST
This incident affected: Circle and Circle Premium.