Circle is unavailable
Incident Report for Circle
Resolved
This incident has been resolved. We have identified the root cause and will be taking steps to prevent this issue from reoccurring.
Posted Apr 28, 2021 - 23:40 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 28, 2021 - 23:35 PDT
Investigating
We are investigating an issue with all Circle services.
Posted Apr 28, 2021 - 23:34 PDT
This incident affected: Circle, Circle Premium, and Website.