Purchasing & Managing Circle Premium is Unavailable
Incident Report for Circle
Resolved
This incident has been resolved.
Posted Jan 24, 2024 - 04:05 PST
Identified
Purchasing or managing Premium is temporarily unavailable due to technical issues with our subscription billing partner. Please contact Circle's support team for urgent inquiries or changes. Existing subscribers can contact Circle Support to enable or disable servers.

We apologize for the inconvenience, rest assured we are working closely with our billing partner to resolve the incident.

Incident updates will be posted here.
Posted Jan 24, 2024 - 01:10 PST