Issues with PayPal Payments
Incident Report for Circle
Resolved
The PayPal team has resolved these issues.
Posted Oct 07, 2021 - 10:51 PDT
Investigating
We are aware of issues when attempting to purchase Circle Premium with PayPal. We are investigating.
Posted Oct 06, 2021 - 12:41 PDT