Degraded Website Performance
Incident Report for Circle
Resolved
This incident has been resolved.
Posted May 10, 2022 - 16:08 PDT
Identified
We are aware of Circle users experiencing elevated errors and higher than normal latency when using the dashboard.

Our team has identified the issue and is taking steps to mitigate the problem.
Posted May 10, 2022 - 16:01 PDT
This incident affected: Website.