Critical Service Outage
Incident Report for Circle
Postmortem

This incident was caused by upstream problems - we are eagerly awaiting a postmortem from them and will complete an analysis of the incident to see if there’s anything we can learn from or change within our own infrastructure to prevent similar issues.

Posted Jun 21, 2022 - 00:51 PDT

Resolved
All systems are operational - this incident has been resolved.
Posted Jun 21, 2022 - 00:50 PDT
Monitoring
All services are operating as normal, we'll continue to monitor and ensure system health.
Posted Jun 21, 2022 - 00:42 PDT
Update
Our primary servers are reconnecting to Discord now, we expect a full recovery shortly.
Posted Jun 21, 2022 - 00:21 PDT
Update
This incident seems to be caused by ongoing service issues @ Cloudflare: https://www.cloudflarestatus.com/incidents/xvs51y9qs9dj
Posted Jun 21, 2022 - 00:00 PDT
Update
We have temporarily relocated Circle Premium to a server located in western Canada, this seems to have brought it back online. We're looking into similar options for production.
Posted Jun 20, 2022 - 23:58 PDT
Identified
Circle is unavailable due to issues @ Discord.
https://discordstatus.com/incidents/7bgt58ndx2s8
Posted Jun 20, 2022 - 23:52 PDT
This incident affected: Circle, Circle Premium, and Website.