Upstream Provider Outage

Incident Report for Circle

Resolved

All services should be back up and running normally! We appreciate your patience.
Posted Mar 17, 2026 - 10:16 PDT

Update

Circle and the website have been restored and are now operational. Premium services remain unavailable while our upstream provider continues to mitigate the issue.
Posted Mar 17, 2026 - 09:45 PDT

Identified

Circle, Circle Premium, and the website are currently unavailable due to an ongoing incident at an upstream hosting provider. We are monitoring the situation and service will restore as soon as the provider resolves the issue.
Posted Mar 17, 2026 - 08:45 PDT
This incident affected: Circle, Circle Premium, and Website.