Major Outage
Incident Report for Circle
Resolved
GalaxyGate has resolved the issue. Circle has scheduled maintenance later this evening at 9:30 PM PST.
Posted Nov 19, 2020 - 21:07 PST
Update
Our hosting provider is currently having issues, we are awaiting an update from them.
Posted Nov 19, 2020 - 20:42 PST
Investigating
We are currently investigating this issue.
Posted Nov 19, 2020 - 20:41 PST
This incident affected: Circle and Website.