Upstream Provider Issues

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 18:23 PDT

Monitoring

A fix has been implemented. You may notice Circle come back online in your servers, and the website is back online. We are monitoring all services.
Posted Jul 30, 2026 - 17:47 PDT

Identified

The issue has been identified.
Posted Jul 30, 2026 - 17:41 PDT

Update

We are continuing to investigate the issue. Circle Premium remains functional.
Posted Jul 30, 2026 - 17:12 PDT

Investigating

We are investigating issues with an upstream provider that is causing issues with regular Circle and the website.
Posted Jul 30, 2026 - 16:26 PDT
This incident affected: Circle, Circle Premium, and Website.